Does Popup Maker Support Multi Language Sites (WPML)?

Popup Maker versions 1.5 and higher offer basic support for WPML so that you can create multiple popups in multiple languages without any issues!

Still need help? Contact Us Contact Us